关于 vivado 兼容性的问题

wujian100 野孩子 ⋅ 于 2021-05-19 10:20:36 ⋅ 最后回复由 小强 2021-05-19 13:02:43 ⋅ 373 阅读

我现在使用的是vivado的2018.3版本,但是打开使用2019.1版本创建的工程会出现版本兼容的问题,于是我首先进行将工程save as之后能够正常打开,然后发现IP核被锁了,之后我将ip进行版本更新
file
再进行编译之后报如下错误:
[Synth 8-439] module 'clk_wiz_0' not found ["F:/JCDL_5th/wujian_n4/wujian_n4.srcs/sources_1/imports/fpga/wujian100_open_fpga_top.v":1173]

但是ip显示它好好的就在那,如图。我真的找不到问题解决方法了,求助。

file

成为第一个点赞的人吧 :bowtie:
回复数量: 1
  • 小强
    2021-05-19 13:02:43

    你这个 IP 什么内容都没有啊,明显升级没有成功,没有这个 IP 实体的,IP 也是会有 .v 文件的,你自己重新生成一个 PLL 就可以了

暂无评论~~
  • 请注意单词拼写,以及中英文排版,参考此页
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`, 更多语法请见这里 Markdown 语法
  • 支持表情,使用方法请见 Emoji 自动补全来咯,可用的 Emoji 请见 :metal: :point_right: Emoji 列表 :star: :sparkles:
  • 上传图片, 支持拖拽和剪切板黏贴上传, 格式限制 - jpg, png, gif
  • 发布框支持本地存储功能,会在内容变更时保存,「提交」按钮点击时清空
Ctrl+Enter